Задача на цикл и условие.

Изображение:
Задача на цикл и условие.
Задача на составление программы в КуМир. Использование цикла и условия.

Задание.

Робот находится в клетке А. Он должен был переместиться в точку Б. Необходимо отметить все закрашенные клетки.

Пример решения.

нц 7 раз

если справа свободно то
вправо
закрасить
все
если снизу свободно то
вниз
закрасить
вверх
все
если сверху свободно то
вверх
закрасить
вниз
все
кц

23:45
360
Нет комментариев. Ваш будет первым!
Загрузка...

Соц. сети