Цикл "n раз"

Алгоритм с повторением в системе программирования КуМир.
Конструкция и пример записи.

В системе КуМир цикл "n раз" записывается при помощи следующей конструкции:

нц n раз
набор команд
кц
n - число повторений цикла.

Пример алгоритма для исполнителя Робот в системе КуМир:\


использовать Робот
алг задание
нач
нц 5 раз
вправо
закрасить
кц
кон


В результате работы программы исполнитель Робот пройдёт вправо на 1 клетку и закрасит её. Замем повторит те же действия ещё 4 раза. Таким образом, Робот переместится вправо на 5 клекток и закрасит их.


Статью подготовил
учитель информатики
Лосев Антон Владимирович

22:40
503
Нет комментариев. Ваш будет первым!
Загрузка...

Соц. сети